Печать картинки в чеке ККМ (для УТ 10.3 и АТОЛ Драйвер ККТ 10.4.5.0)

Публикация № 1051197

Учет и отчетность - Кассовые операции

картинка изображение Чек ККМ реклама

6
Как я пытался на ККТ Атол 25Ф напечатать картинку в "Не фискальном чеке", а в дальнейшем уже печатать небольшую рекламу после основного чека.

Среда окружения:

Windows 7,

1С УТ 10.3 ПРОФ (любая типовая конфигурация от 1С на обычных формах);

Платформа 8.3.12;

АТОЛ Драйвер ККТ 10.4.5.0 (можно взять на сайте Атола тут).

 

Существует масса обработок по печати чека, но порыв интернет так и не нашел подходящего для меня механизма печати картинок или изображения. По этому пришлось изучить документацию Требования к разработке драйверов для ККТ с функцией передачи в ОФД, а именно функцию НапечататьТекстовыйДокумент(PrintTextDocument) где написано, что она может печатать только Текст с Штрихкодом или QR-кодом. 

 

Ну раз "Интеграционная компонента 1С от Атол" не может тогда идем непосредственно к Драйверу АТОЛ ККТ. 

Пример использования в модуле объекта ЧекККМ:

Функция ФискализироватьЧек(ФУ, ДопДанные, Ответ, Отказ)

	//++Основоной текст процедуры
	//.............................
	//--Основоной текст процедуры

	//++Печать Документа с картинкой
	Если НЕ ЗначениеЗаполнено(ОшибкаТО) Тогда
		РезультатДокСКартинкой = ПечатьТекстовогоДокументаСИзображением(ОбработкаОбслуживания, ОбъектДрайвера, МассивСтрок);
		Если Не РезультатДокСКартинкой Тогда
			Сообщить("Не удалось выполнить печать документа с картинкой!");
		КонецЕсли;
	КонецЕсли;
	//--Печать Документа с картинкой
	
	Возврат Результат;

КонецФункции // ФискализироватьЧек()

Итог получился вот такой.

P.s. Если не печатается!

 
 Основные ошибки при выполнении печати:

 

6

Скачать файлы

Наименование Файл Версия Размер
Печать картинки в чеке ККМ (для УТ 10.3 и АТОЛ Драйвер ККТ 10.4.5.0):
.epf 9,75Kb
22.04.19
9
.epf 1.0 9,75Kb 9 Скачать

См. также

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение